Not private connection Error on my.clickmeter.com
Incident Report for ClickMeter
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 13:29 UTC
Identified
We are aware of the "Not private connection" error displayed when accessing my.clickmeter.com.
Redirection and tracking are fully operational.
Posted Feb 06, 2023 - 13:06 UTC
This incident affected: ClickMeter Dashboard.